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1. Specifications

• Memory: 128kB (approx. 3 hour record with 0.1s sampling) 

• Sample time: 0.1 – 25.5s (user selectable with step 0.1s)

• Dimensions: 27 x 14 x 6mm (1.07x0.55x0.24inches)  
Cable length 20cm (7.84 inches)

• Weight: 4.5g with JR cable (0.01 pounds)

• Power supply range: 4 – 12.6V

• Integrated altimeter switch

• F5J FAI rules compatible

• Temperature record

• Record of repeated motor switch on during competition flight

• Indicating LED (Indicating sample time of Switch on altitude)

• Upgradeable firmware

• USB interface with USB cable

• AerobTec Altis Flight manager software for Windows

2. Introduction

The AerobTec Altis v3 is a barometric altimeter designed especially to record altitude of flying R/C aircraft  
with additional competition functionality. It has very small dimensions and a low weight.

It senses barometric pressure variations caused by changes of altitude in which the altimeter is located. 
The altitude is then calculated from pressure data and stored in the internal memory of the device.

It  is  provided with  a system which connects it  to  a personal  computer  with  Windows (XP or  higher) 
operating system via USB. The supplied program cannot only read the information from the device and  
save it to the computer in various formats but it can display it in an advanced graph and process the flight  
information in many ways.

This altimeter has functions based on rules of F5J FAI and Altitude limiting competitions, so it can be used 
for them.

The device and the software also provide some other  complementary functions such as temperature 
measurement and records.

3. Principle

Altis v3 uses a modern fast digital pressure sensor which allows sensing the lowest pressure differences 
corresponding to approx 13cm altitude resolution with sample time up to 0.1s.

Since the  atmospheric  pressure  changes in  time,  these  changes affect  the  measuring.  Which is  the 
reason why long term measurements may not be precise enough. However, altitude in short term flights,  
which are common in R/C aircraft, can be recorded very precisely. It is recommended to set the initial 
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altitude before each flight by disconnecting and connecting to power supply.

The measured altitude is then stored in the internal memory with high capacity which allows around 3 
hours of recording with the fastest sampling. 

4. Hardware description

Hardware of the device consists of 3 parts: the main measuring unit, USB adapter and USB cable. Only  
main measuring unit is used for the flight. Photo of the USB adapter and the main measuring unit is shown 
in Fig. 1.

Fig. 1. Altimeter unit + USB interface unit

Main measuring unit

The main measuring unit consists of 3 connectors. The communication connector connects to a computer 
via USB adapter. 

Power supply and input are provided via a standard JR cable which should be connected to standard R/C 
receiver. Output is provided on pin connector where the main motor is connected.

Mounting in the aircraft

Since AerobTec Altis v3 uses atmospheric pressure measurement, it has to have open access to the outer 
atmosphere. It must not be hermetically closed inside the fuselage or other box. Standard R/C aircraft is  
not hermetical, so it is usually not necessary to do any special modifications. The main measuring unit can  
simply be put in some free space inside the fuselage. 

If the main measuring unit is mounted outside the aircraft, it must be mounted under stricter conditions. It  
must be mounted away from the airflow caused by the propeller.

Connection for competitions 

For competition use (like HL200m, FxJ, F5J FAI) the input JR cable has to be connected to the R/C 
receiver, while the ESC JR cable has to be connected to the output connector on the main measuring unit  
board. Connection diagram can be seen in Fig. 2. The signal polarity must be kept as shown in Table 1.
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Fig. 2. Connection scheme for competition use

ESC – electronic speed controller

THRO – throttle receiver channel 

Wire color Signal
brown Ground

red Positive power supply
orange R/C signal

Table 1: Connection of the connectors

Connection for sole logger function

If the Altis v3 device is used as pure logger device, please connect device in free receiver channel as 
shown in Fig. 3. The signal polarity must be kept as shown in Table 1.

  

Fig. 3. Connection scheme for pure logger use

FREE – free receiver channel 
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USB adapter and its connection

When the measured data need to be read or when new configuration is to be set, the main measuring unit  
has to be connected to computer according to Fig. 4. Please, note the spot on the package on both main 
measuring  unit  and  USB adapter.  Both  of  them must  be  on  the  same side.  Provided  USB cable  is  
connected in the USB connector on the USB adapter.

Fig. 4. USB adapter connection scheme 

Light indication

There is a red LED on the AerobTec Altis v3 device. When the device is turned on, the LED indicates  
changes in its state for every sample. If the sampling time is 0.5s, the LED turns on and off within 1s.

If F5J FAI mode is set, the LED indicates F5J start altitude in the following form. Each digit is indicated by  
a corresponding number of short blinks. Zero is represented by a long blink. Digits are separated by a  
short pause, while the altitude is repeated permanently and separated by a long pause.

See the following examples:

     –  –        –  –  –  –        –  –  –  –  –  –                   –  –        –  –  –  –        –  –  –  –  –  – 246m

     –        ––––        –  –  –  –  –  –  –                    –        ––––        –  –  –  –  –  –  – 107m

5. AerobTec Altis Flight manager PC application

The AerobTec Altis Flight Manager is a PC application which serves to communicate with the device and 
to display and  process the flight data recorded by it.

Requirements

• Windows XP or higher

• 256MB RAM or More

• min 20MB of free disk space

• free USB port

• .NET Framework 2.0. or higher (can be installed from enclosed CD)

• 1GHz Pentium III or Athlon, or better 

• 1024x768 pixels screen resolution

Installation

Application

The AerobTec Altis Flight Manager installation program is available on the enclosed CD in  Application 

AerobTec Altis v3 User Manual 6



folder. Please make sure that an older version of application is correctly uninstalled. For AerobTec  Altis 
Flight  Manager installation execute installation program and follow the installation instructions on the 
screen.

USB Driver

The provided  USB adapter  serves  as a  virtual  serial  port  and  requires  a  USB driver.  An installation  
program for USB driver for Windows (XP or higher) is available on the enclosed CD in Driver folder. For 
proper installation on your PC please execute this program and follow the installation instructions on the  
screen.

.NET Framework

The AerobTec Altis Flight Manager application also requires .NET Framework 2.0 or higher to be installed  
on the computer. It can also be installed from the enclosed CD. User can find .NET installation file in  
dotNet_Framework folder. Please follow the installation instructions on the screen. 

User interface

Main window

The main window contains several parts. There is a main menu, toolbar, flight list, flight description frame  
and flight properties frame with information about the selected flight.

The flight list can be loaded from a file from the menu File → Load or from Start tab. Edited flights can be 
saved by File → Save or new file can be selected by File → Save as. A new file or recent files can also be 
loaded.

Graph functions

The recorded flight data can be seen visually in a graph. The chosen flight is displayed in the Graph tab.

Altitude, vario, temperature and markers can be shown according to the properties selected in the Graph 
menu (Fig. 5.).

Fig. 5. AerobTec Altis Flight manager PC application main window
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The graph can be zoomed in and out or set to basic scale by buttons in toolbar or tool menu. 

When the Zoom in function is on, user can also use the middle mouse button for advanced graph zooming 
and moving. When the middle button is pressed and user moves the mouse, the graph moves while the  
mouse wheel zooms in and out.

The program also offers a graph measuring function available in the Tools menu or in the toolbar. When 
the function is activated, user clicks on the graph at the chosen time and moves the cursor. There is a 
triangle connecting the graph point at the start time and a graph point at the cursor time. Time difference, 
altitude difference and average climbing are shown on the graph. This is shown in Fig. 6.

Fig 6. Measuring function

When a flight is recorded, there may be some parts in the beginning and in the end of the flight which are  
not interesting for the user or user wants to split the flight into two or more flights. User can discard these 
parts by using  Trim Graph Start tool and  Trim Graph End tool and split flight using  Split Graph tool 
available in the toolbar and Tools menu.

Each flight recording begins in the reference altitude, which is always 0m. However, user might know the 
altitude the aircraft starts in. This altitude can be set in the graph by the Set Zero Altitude tool, which is 
also available in Tools menu and the toolbar.

Since the vario data is very noisy, there is a filtering feature available in Graph → Vario Settings... Filter 
value can be selected manually. The filtered graph is shown online. The difference of the same value with 
a different filter value is shown in Fig. 7. The displayed graph can be exported to an image file, csv file or 
html page via Graph → Export. 
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Fig. 7. Comparison of vario signal filtered with different filter settings

Flight description tab

User can add a note to each flight and each marker of the flights. This is possible in the Flight Description 
tab. Information such as Pilot Name and airport name can be added too. User can also edit the time and  
date of the flight in Flight Properties. 

Flight properties frame

This statistical information is shown in this frame: 

• Flight length

• Sample time

• Maximum altitude

• Minimum altitude

• Maximum vario

• Minimum vario

• F5J altitude (if available)

Flights Comparer

Sometimes user might wish to compare several different flights. It is possible via Flight Comparer function  
available in Tools → Flights Comparer.... User opens the file with saved flights and checks the checkboxes 
of the files to be compared. An example of such a comparison is shown in  Fig. 8. The graph can be 
zoomed in and out and moved using the middle mouse button. The displayed graph can be exported to an 
image or printed.
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Fig. 8. Flight comparer

Program settings

Basic settings of the program are available in the Settings window which can be found in File → Program 
Settings....  User  can  choose  preferred  language,  length  units  (meters,  feets  and  yards)  and  the 
communication port where the Altis v3 device is connected. The button Search Device checks all available 
Com ports and recommends user port with active AerobTec Altis v3 device. 

Fig. 9. Settings window

Altis v3 window

This  form  communicates  directly  with  connected  AerobTec  Altis v3  device.  It  is  available  in 
Tools → Altis v3... or in the toolbar. When opening the window, the device should be connected; otherwise 
it will not be opened. During the launch, the settings of the device are loaded and shown in the window.  
User can change the sampling time in the range from 0.1 to 25.5s with step of 0.1s. The serial number of  
the device as well as firmware version and actual memory usage are also shown here.

There are some settings regarding competition rules. User can select altitude switch function, time switch 
function or F5J FAI competition settings. In some competitions it is not allowed to switch the motor on  
again during the flight. However, it is desirable to have the possibility to switch the motor on again in an  
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emergency. User can choose to enable this or not. If enabled, the emergency switch on is recorded and 
can be shown on the flight graph.

User has three possibilities to trigger the recording of data. It can be triggered from certain altitude, by RC 
signal or the recording can be always on.

Fig.10. Altis v3 window

User can read the settings from Altis v3 device again and write the new settings to it. The recorded flight 
data can be read by button Read Data. After reading, the memory of the device can be erased to obtain 
more space for new flights. However, user can continue using the free memory for new flights. 
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6. Warning

It is not recommended to supply whole aircraft via AerobTec Altis v3 device, however it is possible. The 
best choice is to use external BEC circuit.

Do not mount the AerobTec Altis v3 device on aircraft components which might be hot in operation (ESC, 
batteries)!

Do not touch the AerobTec Altis v3 device on the metal surface, as this might lead to shorting of the power  
supply and RC system may failed.

Do not put the AerobTec Altis v3 in water, fuel and other liquids!

Before flying with the Aerobtec Altis v3 device always check the RC system range!

7. Product Registration

If  you  did  not  purchase  the  product  directly  from  AerobTec  please  mail  following  information  to 
sales@aerobtec.com. By registering your products you will be informed about updates and notifications.

Name :

Address* :

Country :

Phone* :

Email :

Product :

Serial number of product :

Date Purchased :

Where did you purchased your product? :

* this information is not obligatory 

8. Revision History

Rev. 1.0. (October 2011)

• Initial release

Rev. 1.1 (January 2012)

• Added Figures

• Change in introduction chapter

• Minor corrections
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